Tagged: 

This topic contains 6 replies, has 3 voices, and was last updated by  neilarnold 1 week, 1 day ago.

  • Author
    Posts
  • #9330

    aridaniv
    Participant

    I use piklist on wordpress 5.1

    Try to create a slider widget with the file field, but it can’t be saved.

    Is piklist not compatible with the latest wordpress?

    Need help.

    Slider-form.php

    piklist('field', array(
        'type' => 'text',
        'field' => 'my_text',
        'label' => 'Text',
        'attributes' => array(
          'class' => 'regular-text'
        )
      ));
    piklist( 'field', array(
      'type'    => 'group',
      'field'   => 'slider_group',
      'add_more'  => true,
      'label'   => __('Slider Expert4you', 'expert4you'),
      'fields'  => array(
        array(
          'type'  => 'file',
          'field' => 'slider_image',
          'label' => __('Slides', 'expert4you'),
          'columns' => 12,
        )
      )
    ) );

    Slider.php

    <?php
    /*  
    Title:  Slider Widget
    Description:  Slider Widget
    Standalone: true
    */?>
    <?php echo $before_widget; ?>
    
    <?php echo $before_title; ?>
    
    <?php echo $settings['my_text']; ?>
    
    <?php echo $after_title; ?>
    
    <?php echo $settings['slider_group']; ?>
    
    <?php echo $after_widget; ?>

    Thanks

  • #9334

    Steve
    Keymaster

    @aridaniv– Welcome to the Piklist community!

    Currently, Piklist does not play nice with Gutenberg. If you use the Classic Editor plugin it should work fine:

    Classic Editor

    Let us know.

  • #9336

    aridaniv
    Participant

    Hi, thank you for answering.

    The problem that arises is when using widgets made using piklist. Some fields cannot be used, for example when choosing colors using the color picker, the save button is not active. And also when choosing an image the widget button remains inactive, so it’s not saved.

  • #9338

    Steve
    Keymaster

    Is the “Classic Editor” plugin active?

  • #9341

    aridaniv
    Participant

    Yes, “Classic Editor” is active

  • #9356

    Steve
    Keymaster

    I was able to reproduce.

    So, Piklist is not 100% compatible with WordPress 5.0+. Many features will work with the Classic Editor plugin, but not all.

    We’ll address this when we come out with our Gutenberg compatible version of Piklist.

  • #9362

    neilarnold
    Participant

    Do you have an ETA for the updates? I use PikList on 4 sites and all of them are having difficulty saving their forms.

You must be logged in to reply to this topic.