Viewing 3 reply threads
  • Author
    Posts
    • #3988
      poxtron
      Member

      Hi, I got this notice on the new update.

      Notice: Undefined index: disable_emojis …

      And I have a feature request, why not add a field for extra css on login screen so we can change the image size, that is all that is missing for it to be a perfect customization of the login screen.

    • #3995
      Steve
      Keymaster

      @poxtron– Please post the full Notice and which url you see it on.

      Instead of actual CSS, would two fields: height and width, be fine?

    • #4035
      poxtron
      Member

      I have a warning on login page

      
      Warning: getimagesize(.../wp-content/uploads/2015/05/logo.png): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in .../wp-content/plugins/wp-helpers/wp-helpers.php on line 706
      

      It’s becase im working on a local server so when getimagesize() tries to fetch the image it cannot find it because it uses the image url I fixed it look

      Change this

      
        public static function login_css()
        {
          $image_id = is_array(self::$options['login_image']) ? self::$options['login_image'] : array(self::$options['login_image']);
          shuffle($image_id);
          $image_url = wp_get_attachment_url($image_id[0]);
      
          $size = getimagesize($image_url);
          
      ?>
          <!-- WP Helpers -->   
          <style type="text/css">  
            .login h1 a {
              background: url(<?php echo esc_url_raw($image_url); ?>) no-repeat top center;
              width: <?php echo $size[0]; ?>px;
              height: <?php echo $size[1]; ?>px;
            }
          </style>
      <?php
        }
      

      To this near line 700

      
        public static function login_css()
        {
          $image_id = is_array(self::$options['login_image']) ? self::$options['login_image'] : array(self::$options['login_image']);
          shuffle($image_id);
            $image_url = wp_get_attachment_image_src($image_id[0],'full');
      ?>
          <style type="text/css">  
            .login h1 a {
              background: url(<?php echo esc_url_raw($image_url[0]); ?>) no-repeat top center;
              width: <?php echo $image_url[1]; ?>px;
              height: <?php echo $image_url[2]; ?>px;
            }
          </style>
      <?php
        }
      

      This way it does not have to make an http request to the image.

      and also I have this nottice on Writing tab.

      
      Notice: Undefined index: disable_emojis in .../wp-content/plugins/wp-helpers/parts/settings/writing-editor.php on line 26
      

      This framework has saved me a lot of time. 🙂

    • #4038
      Steve
      Keymaster

      @poxtron– v1.8.2 is now available at WordPress.org and it has your fixes. Thank you so much!

      Would you mind telling the world that WP Helpers saved you lots of time, but leaving a 5 Star review at WordPress.org? It really helps keep the project going.

Viewing 3 reply threads
  • The topic ‘notice on new update’ is closed to new replies.