Viewing 8 reply threads
  • Author
    Posts
    • #10840
      sjoseph
      Participant

      Hi, when I installed PikList, I got the attached error code. When I changed my php version to 7.3 however it went away.

      Attachments:
      You must be logged in to view attached files.
    • #10842
      Steve
      Keymaster

      @sjoseph– thanks for reporting. We’ll take a look.

    • #10843
      thor
      Participant

      I have the same warnings/notices on various sites:

      Around 20 notice lines lines with:

      Notice: Trying to access array offset on value of type null in /var/www/example.com/public_html/wp-content/plugins/piklist/includes/class-piklist-meta.php on line 352
      Notice: Trying to access array offset on value of type null in /var/www/example.com/public_html/wp-content/plugins/piklist/includes/class-piklist-meta.php on line 354

      and one of these:
      Warning: Cannot modify header information - headers already sent by (output started at /var/www/example.com/public_html/wp-content/plugins/piklist/includes/class-piklist-meta.php:352) in /var/www/example.com/public_html/wp-admin/admin-header.php on line 9

    • #10844
      Steve
      Keymaster

      Thanks. We’re working on a fix.

    • #10881
      Steve
      Keymaster

      This has been fixed in v1.0.10… now available at wordpress.org.

    • #10882
      thor
      Participant

      Perfect! I can confirm it works on multiple Piklist-powered sites. Keep up the excellent work 🙂

    • #10883
      thor
      Participant

      But I do get a (possibly) new error/notice:
      Notice: Trying to access array offset on value of type bool in /var/www/.../wp-content/plugins/piklist/includes/class-piklist-meta.php on line 126

      I am not sure if this came with the new version? Or what to try in order to fix the problem.

    • #10885
      Steve
      Keymaster

      @thor– are you getting that error on all pages or just some. If just some, please post the urls here.

    • #10886
      thor
      Participant

      it is in the admin when editing a page og post (that is, if the post type had any piklist metaboxes). 5-10 lines with that error.

Viewing 8 reply threads
  • You must be logged in to reply to this topic.