This topic contains 8 replies, has 2 voices, and was last updated by  Steve 1 month ago.

  • Author
    Posts
  • #9445

    conkid
    Participant

    I can’t sort out why images are not displaying for file fields.

    See attached? It happens to my code and the demo code. The images just show up as a line. I’m working through the major update from 0.9.4.31 to 1.0.4 and I’ve noticed these two issues.

    Add_more field data will not save to the database.

    Images will not display on the backend for file fields.

    Please advise?

    Attachments:
    You must be logged in to view attached files.
  • #9447

    Steve
    Keymaster

    Were you prompted for the upgrade script? Did you run it?

  • #9448

    conkid
    Participant

    Yes I was prompted. Yes I ran it and it said successful.

  • #9449

    conkid
    Participant

    Steve – I have this in a staging site now and have tested multiple scenarios of upgraded from 0.9.4.31 to 1.04. Could we schedule a remote session and I could show you what is happening?

    I am also noticing now that even before upgrading 0.9.4.31 the add_more field is not saving properly.

    Kind of at a loss on this one. Have been using piklist for approx 3 years.

  • #9452

    conkid
    Participant

    Spent the whole day trying to figure out how to get this site on the new version of piklist.

    When I run the plugin update it breaks the following:

    – add more fields will not save to database
    – post-relate checkbox fields will not save to database
    – images and regular fields DO save to database properly
    – image previews are broken on the backend

    I love Piklist but this is really bad form in my opinion to try to go baseline on the current production version. Please help.

  • #9453

    Steve
    Keymaster

    Here’s what I recommend:
    1. Follow these instructions but instead of installing the latest version, install one version up. https://docs.piklist.com/faq/update-script-not-running/
    2 keep doing that. Install one version at a time. You don’t have to follow those instructions after the first update, meaning you don’t have to delete anything from the database.

    Let’s see if that works

  • #9454

    Steve
    Keymaster

    You can get all they older versions here: https://wordpress.org/plugins/piklist/advanced/

  • #9465

    conkid
    Participant

    Hey Steve,

    I figured it out. The add more that wasn’t functioning was assigned to a page template. The site had since had Gutenberg installed w/ the 5.0 release of WP. Once I disabled gutenberg functionality I was able to update the fields as expected. Very odd but maybe I missed some notice about gutenberg editor breaking field enhancing plugins?

    Thanks for your help.

  • #9466

    Steve
    Keymaster

    Glad you figured it out!

    Piklist does not support Gutenberg yet. You have to use the Classic Editor plugin https://wordpress.org/plugins/classic-editor/

The topic ‘Upload Field – No Image on Backend’ is closed to new replies.