Forum Replies Created

Viewing 15 posts - 31 through 45 (of 72 total)
  • Author
    Posts
  • in reply to: Can't remove file with the file field #2828
    kattagami
    Member

    Do someone has a patch or any idea how to resolve this bug?

    in reply to: Bug with the "New" attribut when creating a metabox in a CPT #2744
    kattagami
    Member

    Yes…
    But in fact I don’t really need this features at the moment. I just notice the bug so I wrote this message to let you know and to check if it’s a reproducible bug.

    in reply to: Bug with the "New" attribut when creating a metabox in a CPT #2742
    kattagami
    Member

    In my case, this bug appends with and without workflow.

    For instance, if you test the demo plugin available in this thread:
    https://piklist.com/support/topic/bugs-with-validation/

    … where there is no Workflow, and add the “New: true” attribut in the top comments, the metabox disappears.

    in reply to: Changes not preserved when switching between workflow tabs #2585
    kattagami
    Member

    I’m agree with wpkonsulterna and this feature is often requested by my users.

    in reply to: Can't remove file with the file field #2548
    kattagami
    Member

    Just for information, this bug occurs both on the Basic uploader and the standard Media uploader.

    in reply to: Problem with widget on my local installation #2536
    kattagami
    Member

    After several tests on different environments, I can reproduce the bug even on Apache:

    – Set WP_DEBUG to “true” in your config.php file
    – Activate the plugin “testwidget” http://we.tl/pLe6lMdC3g (it’s a simple plugin with a Piklist widget)

    in reply to: Problem with widget on my local installation #2533
    kattagami
    Member

    … I asked to a friend to test the Piklist widget on his Nginx + php-fpm install and he’s got the same errors (notices).

    So it seems there is something wrong between Piklist and Nginx/php-fpm :-/

    in reply to: Problem with widget on my local installation #2529
    kattagami
    Member

    Hello Steve,

    So I’ve re-installed my web server, deleted my database and re-installed WordPress.
    I’ve tested with only Piklist an my widget plugin and different WP theme (2014, blankslate …)

    … and always the same notices and no Title for my Piklist widget
    Notice: Undefined variable: title in …wordpress/wp-content/plugins/piklist/includes/class-piklist-widget.php on line 82
    Notice: Undefined variable: description in …wordpress/wp-content/plugins/piklist/includes/class-piklist-widget.php on line 82

    I tried on another remote server (Nginx not Apache) and I’ve got the same error.
    These errors display even with the Piklist Demos activated I said no in my previous message but in fact it’s “yes”

    define(‘WP_DEBUG’, true); must be set to “true” in the config file.

    I think the problem could come from Nginx or my Nginx config web file?
    Do you have an Nginx server to test the Piklist widgets?

    If no tell me, I maybe could ask someone on the forum.

    in reply to: Disable drag and drop reorder on add_more fields #2526
    kattagami
    Member

    Mhmm … remove the “ui-sortable” class from the <td> doesn’t seem to disable the drag and drop reorder.

    in reply to: Problem with widget on my local installation #2522
    kattagami
    Member

    Hello Steve,

    Yes the demo works perfectly, this problem makes me crazy so I’ve decided to re-install all my server, clean my database and re-install WordPress on my local PC. I will let you know the result.

    PS : Is there any reason why the version of Piklist came back to version 0.9.4.12 since yesteday on your website and on the WP repository? Mine is 0.9.4.17 …

    in reply to: Disable drag and drop reorder on add_more fields #2515
    kattagami
    Member

    Thanks very much Jason, I’m going to try your js solution 🙂

    in reply to: Can't remove file with the file field #2502
    kattagami
    Member

    … and do someone have the same wide border around the file (see screenshot below) ?

    WordPress Multisite 4.0
    Piklist 0.9.4.17

    in reply to: New Conditional Bug… YAAAY! #2194
    kattagami
    Member

    Thanks Marcus,

    Now I can see my two conditional fields and I’ve got the same bug as you.

    I didn’t see in the Piklist “User Guide” that we need to reference the outside group name inside the conditional.
    Where did you see this instruction?

    in reply to: New Conditional Bug… YAAAY! #2192
    kattagami
    Member

    This is my contribution:

    This code works perfectly but if I put it in a group/add-more field it doesn’t work anymore.

    NO group/add-more

    piklist( 'field', 
    	array(
    		'type'        => 'radio',
    		'scope'       => 'post_meta',
    		'field'       => 'katt_schedule_choice',
    		'value'       => 'show', // Sets default to show
    		'label'       => 'Choose a Break or a Presentation',
    		'help' 		  => 'To build your schedule you can insert a presentation or a break.',
    		'attributes'  => array(
    		  		'class' => 'text',
    								),
    		'choices' => array(
    				'presentation'  => 'Presentation',
    				'break'         => 'Break',
    		    				),
    		  		
    		)
    );
     
    piklist( 'field', 
    	array(
    		'type'        => 'text',
    		'field'       => 'katt_schedule_break',
    		'label'       => 'Break',
    		'help'        => 'If you need to insert a break (Welcome, Coffee, Lunch ...) in your schedule, use this field.',
    		'conditions'  => array(
          				    array(
    					'field'   => 'katt_schedule_choice',
    					'value'   => array( 'presentation' ),
    					'compare' => '!='
        							),
        						),
    		)
    );
    
    piklist( 'field', 
    	array(
    		'type'        => 'select',
    		'field'       => 'katt_schedule_presentation',
    		'label'       => 'Presentations',
    		'help'        => 'Choose a presentation to build your schedule.',
    		'conditions'  => array(
          					array(
    					'field'   => 'katt_schedule_choice',
    					'value'   => array( 'break' ),
    					'compare' => '!='
        							),
        						),
    		)
    );
    

    IN a group/add-more field:

    piklist( 'field', 
    		array (
    		'type'     => 'group',
    		'field'    => 'katt_schedule_group',
    		'add_more' => true,
    		'label'    => __( 'Presentation or Break' , 'katt' ),
    		'help' 	   => __( 'To build your schedule you can insert a presentation or a break.' , 'katt' ),
    		'fields'   => array(
    		array(
    			'type'        => 'radio',
    			'scope'       => 'post_meta',
    			'field'       => 'katt_schedule_choice',
    			'value'       => 'show', // Sets default to show
    			'label'       => __( 'Choose:' , 'katt' ),
    			'attributes'  => array(
    			  			'class' => 'text',
    									),
    			'choices' => array(
    					'presentation'  => __( 'Presentation' , 'katt' ),
    					'break'         => __( 'Break' , 'katt' ),
    			    				),
    			  		
    			),
    		array(
    			'type'        => 'text',
    			'field'       => 'katt_schedule_break',
    			'label'       => __( 'Break' , 'katt' ),
    			'help'        => __( 'If you need to insert a break (Welcome, Breakfast, Coffee break, Lunch ...) in your schedule, use this field.' , 'katt' ),
    			'conditions'  => array(
    	      					array(
    						'field'   => 'katt_schedule_choice',
    						'value'   => 'presentation',
    						'compare' => '!='
    	    							),
    	    						),
    			),
    		array(
    			'type'        => 'select',
    			'field'       => 'katt_schedule_presentation',
    			'label'       => __( 'Presentations' , 'katt' ),
    			'help'        => __( 'Choose a presentation to build your schedule.' , 'katt' ),
    			'conditions'  => array(
    	      					array(
    						'field'   => 'katt_schedule_choice',
    						'value'   => 'break',
    						'compare' => '!='
    	    							),
    	    						),
    			)
    		)
    	)
    );
    in reply to: Bugs in 0.9.4.0 #2043
    kattagami
    Member

    Same bug for me concerning the reverse order of the tab in my setting page.

    Thx for your work on the 0.9.4 🙂

Viewing 15 posts - 31 through 45 (of 72 total)