Forum Replies Created

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • in reply to: [Bug] Hidden field value #8324
    poxtron
    Member

    I have the same problem. Thanks for posting the answer.

    I hope they push an update to address this issue.

    in reply to: Adding tax meta field on new tax form #4176
    poxtron
    Member

    I think this is an important feature for a complete WP framework I hope this comes back soon. If there is anything I can do to help let me know.

    in reply to: notice on new update #4035
    poxtron
    Member

    I have a warning on login page

    
    Warning: getimagesize(.../wp-content/uploads/2015/05/logo.png): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in .../wp-content/plugins/wp-helpers/wp-helpers.php on line 706
    

    It’s becase im working on a local server so when getimagesize() tries to fetch the image it cannot find it because it uses the image url I fixed it look

    Change this

    
      public static function login_css()
      {
        $image_id = is_array(self::$options['login_image']) ? self::$options['login_image'] : array(self::$options['login_image']);
        shuffle($image_id);
        $image_url = wp_get_attachment_url($image_id[0]);
    
        $size = getimagesize($image_url);
        
    ?>
        <!-- WP Helpers -->   
        <style type="text/css">  
          .login h1 a {
            background: url(<?php echo esc_url_raw($image_url); ?>) no-repeat top center;
            width: <?php echo $size[0]; ?>px;
            height: <?php echo $size[1]; ?>px;
          }
        </style>
    <?php
      }
    

    To this near line 700

    
      public static function login_css()
      {
        $image_id = is_array(self::$options['login_image']) ? self::$options['login_image'] : array(self::$options['login_image']);
        shuffle($image_id);
          $image_url = wp_get_attachment_image_src($image_id[0],'full');
    ?>
        <style type="text/css">  
          .login h1 a {
            background: url(<?php echo esc_url_raw($image_url[0]); ?>) no-repeat top center;
            width: <?php echo $image_url[1]; ?>px;
            height: <?php echo $image_url[2]; ?>px;
          }
        </style>
    <?php
      }
    

    This way it does not have to make an http request to the image.

    and also I have this nottice on Writing tab.

    
    Notice: Undefined index: disable_emojis in .../wp-content/plugins/wp-helpers/parts/settings/writing-editor.php on line 26
    

    This framework has saved me a lot of time. 🙂

Viewing 3 posts - 1 through 3 (of 3 total)